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2. Working with Sophie 

2.1. Sophie’s interface
There are three main parts of the Sophie interface: the workspace, the left flap, and 
the right flap. The workspace is the gray area in the center of the Sophie window. It’s 
the background, but it does things: dragging things onto the workspace will make a 
new Sophie book.

Flaps are the things that stick out on the left and right side of the Sophie window;  
you can adjust the size of the flaps by dragging the orange margin back and forth. 
Each flap has several tabs in it, which can be selected by clicking the tab name. Most 
tabs contain more than one palette. Palettes can be lists of things used in Sophie (like 
all the movies in a book) or tools (like the spellchecker). There’s also a bottom flap, 
which you’ll see when you open a timeline, but this flap doesn’t appear automatically. 

Sophie has menu bars, but they’re not used for very much. Most of the things you 
can do in Sophie can be done through the flaps or halos and HUDs. 

2.2. Halos and HUDs 
Interacting with Sophie is done with halos and HUDs. Halos are little icons that show 
up around things in Sophie when you select them. They stay on the screen until you 
click somewhere else in Sophie. Generally, these halos can be clicked to open a HUD; 
a few work slightly differently. HUD is short for head-up display. It’s a little window 
that opens up showing you different things that you can do with whatever you have 
selected. You can drag a HUD around by clicking on its background and dragging.

Here’s an example. If you click on a blank page in Sophie, a little gray square will 
appear. This is the page halo. If you click it, the page HUD will open. It contains set-
tings that let you control the background color of the page. 

Different things in Sophie have different kids of halos. If you select an image on a 
Sophie page, you’ll see a frame appearance halo, which lets you put images, back-
grounds, or drop shadows on the image; a frame properties halo, which lets you con-
trol where and how big the image is; a link halo, which lets you turn the image into a 
link; and an anchor halo, which lets you attach the image to a text flow. If you select a 
word of text, you’ll see the character halo, which lets you set the font settings for just 
that word; the paragraph halo, which lets you control how the paragraph that word is 
in appears; and the link halo, which lets you make that word into a link. Some halos 
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are very specific: you won’t see the link color halo unless you’ve selected a frame 
that’s a link or text that’s part of a link.

Generally the most used settings in a HUD are near the top of the window. Some-
times you’ll see a downward facing arrow at the bottom of a HUD. These arrows can 
be clicked to unfold more functionality in the HUD (and clicked again to hide the 
functionality). Some HUDs have several of these arrows. 

One special kind of halo is the little clock which appears in the upper right hand 
corner of a frame, image, or movie that is selected on a Sophie page. Clicking on this 
halo doesn’t open a HUD; however, this halo can be dragged to a timeline if you want 
the object to appear on a timeline. (You don’t want to drag the object itself because 
you probably want it to stay in the same place on the page.) The anchor halo can simi-
larly be dragged to the place in a text flow where you want to anchor a frame.

Besides halos, Sophie frames have a few basic controls that appear when the frame 
is selected. The orange edges that appear can be dragged up and down or back and 
forth to change the frame’s size and shape. Corners can also be dragged to change the 
shape of the frame. There’s a little orange circle that appears in the center of the 
frame; this can be dragged to move the frame around the page. (This is especially 
important in text frames: if you click other places inside the text frame, Sophie will 
assume that you want to put your cursor in text.) And finally, there’s a little green 
square in the upper right corner of the frame. If you drag this, you can rotate the 
frame. 

(With some frames, you might see a light gray box outside or inside of the orange 
frame. These frames show margins – extra space outside of a frame – and padding – 
extra space inside of a frame. These are useful when you have text inside of or outside 
of a frame, but they’re not halos. For information about these, see the frame proper-
ties HUD.)

To learn about specific halos and HUDs, choose one from the list: 

OBJECT HALOS:
Frame appearance halo • Frame properties halo • Link halo • Link color halo • 
Anchor halo • Time-based media halo • Align halo 

TEXT HALOS: 
Character halo • Paragraph halo • Link halo • Link color halo 

PAGE HALOS: 
Page halo 
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2.2.1. FRAME APPEARANCE HALO 
The frame appearance halo controls how the frame appears. The frame appearance 
halo allows you to set the background of a frame (which can be a color, a gradient of 
colors, an image, or nothing). Setting the background has no effect on a movie and 
most images, although images with transparency can take on different backgrounds. 
The default background for all frames is solid white. In addition to setting the back-
ground for a frame, this halo can also be used to set a border on a frame and to add a 
drop shadow behind the frame.

Some of the settings in the frame appearance halo use the color picker square. If 
you click on this square, a color picker will appear, allowing you to set the color for 
the selected functionality. 

2.2.2. FRAME PROPERTIES HALO 
The frame properties halo allows you to specify where on the page a frame appears 
(with x and y coordinates) as well as the width and height of the frame. You can also 
use the frame properties halo to change the z-order of a frame (whether it appears 
below or above other frames) and to determine whether text should wrap around a 
frame (by default, text wraps around frames). 

If you unfold the frame properties HUD, there are settings for margins and pad-
ding. Margins are used when you have text inside a frame: they determine how much 
space should come between the frame and the text. Padding is extra space around a 
frame: if you have an image that appears in a column of text, you might add some 
padding to put a margin around it. 

2.2.3. LINK HALO 
The link halo is used to create links. Links in Sophie have three parts: something that 
triggers the link (the reader clicking a frame or text, for example, or the page open-
ing), an action that is performed (a timeline is played, a frame is shown, the book 
jumps to the next page), and finally what’s used to perform that action (the timeline 
to play, the frame to show, the page number to jump to). 

The link HUD includes three windows that are used to represent these three parts 
of the link. The top drop-down menu lists possible triggers. The middle drop-down 
menu lists possible actions to take. And the third drop-down menu changes depend-
ing on what kind of link is selected. If the action is to open a URL, you can type in the 
URL in the third box. If the action is to open a timeline, you can drag the timeline 
from the timeline palette to the third box. If the action is to show or hide a frame, 
drag the little flag near the box to the frame you want to show or hide. 

The + and – at the bottom of the link HUD allow you to make more complex links: 
the same frame or text can be part of several different links. 
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2.2.4. LINK COLOR HALO 
When you’ve created a link, the link color halo appears. When your link is text, the 
link color HUD shows four color boxes: one for the link when it hasn’t been clicked, 
one for when the reader’s mouse is over the link, one for when the reader is clicking 
the link, and the final one for the color the link is after it’s been clicked. If you click 
any of the color squares, a color picker will appear allowing you to change the color 
for the link. 

The link color halo is slightly different if you’ve made a link out of a frame. In this 
case, the link color halo appears a lot like the frame appearance halo: you can set dif-
ferent background and border settings for when the link hasn’t been clicked, when 
the reader mouses over the link, when the reader clicks the link, and when the reader 
has already clicked the link. The drop boxes at the bottom of this HUD allow you to 
drop in other images to fill the frame: this lets you make buttons. 

2.2.5. ANCHOR HALO 
The anchor halo is used to anchor frames to a particular point in a text flow. You 
might do this if you have an image that should appear beside a certain paragraph of 
your text; that paragraph happens to be on page 5 right now, but if more text is added 
below it, it might end up being on page 20. While you could just drop the image on 
page 5 next to the text, if the text changes the image will be on the wrong page; if the 
image is anchored, it will move with the text to which it is attached. 

To anchor a frame in a text flow, drag the anchor halo from the frame you want to 
anchor to the point in a flow frame to which you want to anchor it. A line is drawn 
between the two frames. The anchor HUD then appears. The main thing displayed in 
the anchor HUD is the anchor style, in the drop-down menu; this controls the way in 
which the anchored frame is moved relative to the flow in which it is anchored. 
“Page,” the default style, means that the anchored frame will always appear on the 
same page as the point in the flow to which it is anchored. If the anchor point is at 
the bottom of page 2, the anchored frame will appear on page 2; if the anchor point is 
pushed over to page 3, the anchored frame will appear on page 3 in the same position. 

Other anchor styles are possible. If the style is “inline,” the frame will be moved 
into the text of the flow at the anchor point. You might do this if you want to include a 
small graphic in your text (an elaborate star, for example). 

“Character” positions the anchor relative to the position of the anchor point in the 
line. If you anchor an image with this style to a position at the start of the line, then 
add words before the anchor point, the image will move to the right. If you add lines 
above the anchor point in the flow frame, the anchored image will move down. “Line” 
does the same thing, but doesn’t move the anchored frame relative to the anchor 
point’s position in the line. “Paragraph” moves the anchored object relative to the 
paragraph of the anchor point, so the anchored object will only move when the posi-
tion of the paragraph changes. 
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“Frame” moves the anchored object relative to the frame that the anchor point is 
in. You can use this if you have two frames that you want to keep together: if you 
move the frame that the anchored frame is anchored to, the anchored frame will also 
move.

For “Page,” “Paragraph,” and “Frame,” you can choose a control point: this selects 
which corner (or the center) of the page, paragraph, or frame the anchored object is 
moved relative to. 

Frames can only be anchored in a flow frame or a non-flow frame, though they 
don’t do very much when anchored in a non-flow frame. Once a frame has been an-
chored, you can always open the anchor HUD to change anchor settings. 

2.2.6. TIME-BASED MEDIA HALO 
The time-based media halo only appears on audio and video that has been dragged to 
the page. This is a simple HUD: it includes checkboxes that ask if you want the me-
dia to play when shown and whether a controller should be shown. If “play when 
shown” is checked, the media will start playing as soon as the page of the book that it 
appears on is opened. (What this checkbox does, actually, is to create a link: open the 
link HUD to see what it does.) If “show controller” is checked, play and pause buttons 
are shown that the reader can use. These controller buttons only work in test mode.

2.2.7. ALIGN HALO 
The align halo only appears when more than one frame is selected. You can select 
multiple frames by clicking the first frame, then holding down command or control 
and clicking more frames. If you click the align halo, you’ll be presented with options 
for ways to arrange the frames. It’s an easy way to automatically line up a lot of 
frames quickly. 

2.2.8. CHARACTER HALO 
The character halo is used when you want to change how text looks: you can change 
the font, style, size, and color of the text you’re using. Part of the paragraph HUD 
looks exactly like the character HUD. The ones in the paragraph HUD are character 
settings for the entire paragraph: if you want your entire paragraph to be 36-point red 
Helvetica, you should change it in the paragraph HUD. If you only want a single 
word to be 36-point red Helvetica, you should select that word and change it in the 
character HUD. 

2.2.9. PARAGRAPH HALO 
The paragraph halo is used when you want to change how an entire paragraph looks. 
You can change linespacing; whether the paragraph is left-, center-, or right-aligned; 
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the indentation of the paragraph; and whether space should be added before or after 
the paragraph. If you unfold this HUD all the way, you’ll see character settings. These 
are character settings for the whole paragraph: if you want your entire paragraph to 
be 36-point red Helvetica, you should change it here. If you only want a single word 
to be 36-point red Helvetica, you should change it in the character HUD. 

Paragraph styles can be saved for reuse. If you want all of your headers to be 36-
point centered Helvetica with 18 points of space after them, you can click the little 
disc at the top of this HUD to save the style. You’ll be prompted for a name for your 
style; once you save it, it will appear in the list of paragraph styles in the styles tab. To 
apply this style to another paragraph, insert your cursor in that paragraph, open the 
paragraph HUD, and select the style name from the drop-down menu. Your saved 
settings will instantly be applied. 

2.2.10. PAGE HALO 
The page HUD looks just like the frame appearance HUD and does exactly the same 
things, except to the page itself rather than a frame. The page HUD is a good way to 
set a background for your page. 

2.3. Flaps, tabs, and palettes 
The flaps hold most of Sophie’s functionality that you can’t get at through the halos 
and HUDs. Each flap has tabs in it; each tab has palettes. You can switch tabs by 
clicking on the tab name. By dragging the edges, you can change how big the tabs 
and palettes are.  

The left flap is generally concerned with the structure of your book. In the left flap 
you can find a list of open books, thumbnails of all the pages in your current book, 
and a list of the timelines in the current book. Click on the palette or tab that you’re 
interested in for a more detailed description: 

PAGES
Page palette • Page structure

BOOKS 
Books • Embedded books 

TIMELINES 
Timelines 
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TOOLS 
Searching • Search & replace • Spellcheck 

ANNOTATIONS 
Highlights • Stickies • Audio recording 

The right flap generally contains content that can be used to make books. In the right 
flap you can find book templates, the media that you’ve imported into Sophie, and 
components which can be dragged to the Sophie page. Click on the palette or tab that 
you’re interested in for a more detailed description.

COMPONENTS 
Text frames • Page templates • Book templates 

RESOURCES 
Images • Audio • Movies • Text • Meta 

There’s also a bottom flap, which becomes visible when you open a timeline. Other-
wise this flap isn’t used. 

2.3.1. PAGES TAB 
The pages tab contains palettes that have to do with pages in a Sophie books: the page 
preview palette and the page structure palette. The page structure palette is mini-
mized by default to just its title bar.

Page palette. The page palette shows thumbnails of every page in your book; the 
page you’re currently on has a red outline. If you make the flap wider, the thumbnails 
will get bigger. You can click on a thumbnail to go to that page; pages can also be 
dragged up and down to shuffle them. You can select multiple pages by shift-clicking 
other pages after you’ve selected a page. To delete a page from a Sophie book, select 
the page in the page palette and press DELETE or BACKSPACE. Be careful! 

The page palette is also used when you want to apply a page template to a page. To 
do this, drag the page template you want from the page template palette to the page 
you want to apply it to. To insert a new page, drag the page template before, between, 
or after an existing page in the page palette. 

Page structure palette. The page structure palette shows you a list of all the objects 
on your current page. When you select something on the page it is selected in the 
page structure palette’s list, and vice versa. 
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2.3.2. BOOKS TAB 
The books tab contains palettes that have to do with the books you have open in Sophie.

Books palette. The books palette is a list of all the books you have open in Sophie. A 
book may be open, but its window may not be; to open a book’s window, drag the 
book out from the palette to the workspace. 

Embedded books palette. The embedded books palette is a list of all the books that 
are embedded in (or linked from) the book you currently have open and selected. To 
use an embedded book, you can drag it to the workspace to open its window or drag it 
to a page in the container book to embed it on that page. 

2.3.3. TIMELINES TAB/PALETTE 
The timelines tab only contains a single palette, the timelines palette. The timelines 
palette is a list of all the timelines in your current book; if you double-click one of 
them, you can edit that timeline in the timeline flap at the bottom of the Sophie win-
dow. To add a new timeline to a Sophie book, click either of the two buttons at the 
bottom of the timelines tab; either a single-page timeline or a page-spanning timeline 
will be added to your book and will be opened for editing in the timeline flap. 

2.3.4. TOOLS TAB 
The tools tab contains palettes that are used for editing books: the searching palette, 
the search & replace palette, and the spellchecker. 

Searching palette. The searching palette lets you search a Sophie document. When 
you enter a phrase in the search box, your current flow is searched; results are listed 
with context. Clicking on a result will take you to that page of the book. 

Search & replace palette. The search & replace palette lets you search for words or 
phrases in the text fields of your book and replace them. Enter a phrase to search for 
and one to replace it with; click Replace to replace the first result, or All to replace all 
occurrences. 

Spellcheck palette. The spellchecker palette allows you to spellcheck your book from 
the current flow. To start it, click in a flow and press the Next button.

2.3.5. ANNOTATIONS TAB 
The tools tab contains a bunch of palettes that are used for editing and reading books: 
the searching palette, the highlights palette, the stickies palette, and the spellchecker. 
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Highlights palette. The highlights palette lists all highlights in the current Sophie 
book. You can delete a highlight by selecting its entry in this list and pressing DE-
LETE. Clicking on an entry will take you to the page on which the highlight appears. 
Clicking the Add Highlight button will highlight the text you currently have selected. 
Import Highlights will prompt you for the location of a file of previously saved high-
lights. Save Highlights As will prompt you for a location where a file of the highlights 
of your current book can be stored.

Stickies palette. The stickies palette allows you to make new stickies on a Sophie 
book. Pressing the New Sticky button will make a new sticky on the current page. 
The Enable Stickies checkbox toggles sticky visibility in the book; if this isn’t checked, 
stickies won’t be visible. Import Stickies will prompt you for the location of a file of 
previously saved stickies. Save Stickies As will prompt you for a location where a file 
of the highlights of your current book can be stored.

Audio recording palette. The audio recording palette lets you record audio through 
your computer’s microphone (or line-in) inside of Sophie. To use this, click the red 
Record button; there will be a slight delay (the words “Preparing to record” will ap-
pear to the right of the Play button) and then a clock will start increasing, letting you 
know that Sophie is recording. Click the Stop button when you’re done; click the Play 
button to playback what you’ve just recorded. If you like it and want to keep it, click 
the Save button, which will add the audio in the audio palette of the resources tab. By 
default, recordings are given the time and date they were recorded. If you don’t want 
to keep it, just don’t hit the Save button.

2.3.6. COMPONENTS TAB
The library tab contains building blocks for Sophie books: different kinds of frames 
in the components palette and book templates in the book template palette. 

Text frames palette. The text frames palette contains different kinds of frames that 
can be used in a Sophie book. Frames can be dragged from this palette to the page of 
a Sophie book or to the workspace (where they will create a new book). There are four 
types of frames: flow frame, non-flow frames, non-flow (template content) frames, 
comment frames, and comment (template content) frames. Each does different 
things, though the template content frames are only slightly different from the non-
template content frames. 

When a flow frame is full of text, a new page will be added to the Sophie book to 
hold the extra text. If there are two flow frames on a page, text can flow from one page 
to the next. If you hold down option or alt when dropping a flow frame on a page, 
you’ll create a new flow. You can adjust flow connections using Edit > Show/Hide 
Flow Connections. 
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When a non-flow or a non-flow (template content) frame is full of text, no extra 
page is created: the text doesn’t appear on the page, though it will if you resize the 
frame. Non-flow and non-flow (template content) frames behave in the same way 
unless they are on a template. If a non-flow frame is on a template, the frame can 
have different content on every page; if a non-flow (template content) frame is on a 
template, the same content will appear on every page. 

Comment frames and comment (template content) frames allow readers to add 
comments to a book, much like a blog. Comment frames use Sophie Server; every 
reader who is reading a book with comment frames will see all the comments at-
tached to that frame by other readers when they look at the frame. Comment and 
comment (template content) frames behave in the same way unless they are on a 
template. If a comment frame is on a template, the frame can have different com-
ments on every page; if a comment (template content) frame is on a template, the 
same comments will appear on every page.

Page templates palette. The page templates palette contains all page templates in the 
current book. By default, all books come with two page templates, “default page tem-
plate” and “new blank page”. Page templates can be applied to a page by dragging the 
page template to the page’s thumbnail in the page palette. Pages can be added to a 
book that use a page template by dragging a page template before, between, or after 
pages in the page palette.

Book templates palette. The book templates palette contains all the book templates 
that either came with Sophie or that you’ve saved. Book templates can be dragged to 
the workspace to create a new book using the book template, or dragged to the page 
of an open Sophie book to create a new embedded book. 

2.3.7. RESOURCES TAB 
The resources tab contains all media that’s been imported into Sophie, separated into 
text, images, audio, and video. All of these objects can be dragged from their palettes 
to a Sophie book; if they are dragged to the workspace, a new Sophie book is started 
containing just that resource. The resources tab also contains the meta palette, which 
displays metadata on selected resources. 

Resources can be added to a Sophie book by dragging resources from the com-
puter to the resources tab, by using File > Import File, or by dragging the resources 
directly to the book page. Remote resources can also be added by using File > Link to 
URI (with a URI that points to the remote resource). 

Images palette. The images palette contains a list of all images in the current book. 

Audio palette. The audio palette contains a list of all audio files in the current Sophie 
book. 
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Movies palette. The movies palette contains a list of all movie files in the current 
Sophie book. 

Text palette. The text palette contains all text files that have been imported to the cur-
rent Sophie book. To use a text file in a book, put a frame on the page – probably 
you’ll want a flow frame – insert the cursor in the frame, and then drag the text from 
the text palette to the cursor position and drop it. 

Meta palette. The meta palette displays metadata about any resource that is selected. 

2.3.8. WORKING WITH PALETTES
Palettes (and tabs) can also be dragged out to become free-standing windows: drag 
the title bar of the palette into the Sophie workspace. It will gain a red outline; you 
can position it where you want in the Sophie workspace by dragging its title bar. If 
you click the X in the upper-right corner of a detached palette, the palette will also be 
returned to the original tab that appeared in. Or you can drag the palette over a tab 
and drop it if you want to put it back; palettes don’t necessarily need to go back into 
their original tabs, and you can rearrange Sophie’s interface as you like. 

Some palettes (the books palette in the books tab; the page templates palette in the 
components tab; and the text, images, audio, and video palettes in the resources tab)) 
have a little magnifying glass in the upper right corner. If you click the magnifying 
glass, you can filter the listings in the tab. A search field will appear directly below the 
title bar of the palette; if you type in a string of text and press RETURN, only the re-
sources in the palette that include that text in their name will be shown. To return to 
the full listing, delete the search text and press RETURN again or click the X at the 
right of the field. 

2.4. The menu bars 
The menu bars are only used sometimes in Sophie, but there are some important 
things that can only be accomplished via the menu bars. 

2.4.1. FILE 
The File menu generally contains things having to do with opening and saving So-
phie books and their contents. 

File > New Book makes a new Sophie book. You’ll be prompted for the width and 
height of your new book. This command can also be triggered by command/control-N.

File > Open Book prompts you for the location of a saved Sophie book file on your 
computer. You can do the same thing by pressing command/control-O. 
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File > Open Recent Books displays a list of recently used Sophie books. Click on one 
of them to open it, or click elsewhere to make the list go away. 

File > Close Book will close the Sophie book you currently have selected. You’ll be 
asked whether you want to save changes. You can also do this by pressing command/
control-W, or by clicking the little X button in the book’s title bar. 

File > Hide Book will close the window of the Sophie book you currently have se-
lected but not the Sophie book itself: it will still be in the list of open books in the 
books palette. Use this if your workspace is too crowded and you need more space. 
Command/control-shift-W will do this as well. 

File > Save Book will save your current Sophie book. If you haven’t previously saved 
your book, you’ll be prompted for a name for your book. You can also do this by 
pressing command/control-S. 

File > Save Book As will prompt you for a name to save a copy of your Sophie book 
as. This new file will become the working book file. You can also do this by pressing 
command/control-shift-S. 

File > Save Book Template will save your book as a book template; you’ll be prompted 
for a place to save the book template, which by default is the directory in which So-
phie looks for book templates. Saving your book as a book template will erase all text 
and all pages but the first one. If the book template is saved in Sophie’s default book 
template directory, the new book template will be listed in the book templates palette. 

File > Publish Book exports your Sophie book in a form which can be used in Sophie 
Reader (or in Sophie Author). Published books have the extension .sophie. If you 
choose this, changes to your book will be saved and it will be closed after it is turned 
into a published book. The published version will then be opened.

File > Print to PDF will generate a PDF of your book, which you could use for print-
ing. If you’re on a Mac, Preview (or the application you’ve set to handle PDFs) will be 
opened with the resulting PDF. If you’re on a Windows PC with Adobe Acrobat or 
Reader, Acrobat or Reader will be opened with the PDF. If you don’t have an applica-
tion associated with PDFs in Windows or on a Linux PC, a message will tell you 
where the PDF has been saved. You can also do this by pressing command/control-P.

File > Import Resource from URL will prompt you for the URL of a remote object that 
can be used in a Sophie book. This object will be downloaded and included in the 
current Sophie book’s resources. 
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File > Link to Resource from URL will prompt you for the URL of a remote object that 
can be used in a Sophie book. The object will appear in Sophie’s resources, but the 
object will not be downloaded until the reader looks at it on the page. Use this if you 
want your Sophie book to remain small in size. 

File > Import File does the same thing as dragging an object from your computer’s 
desktop to Sophie’s resources. You’ll be prompted for the location of resources that 
you want to use in Sophie. 

File > Link To File will prompt you for the location of an object on your computer. 
While you’ll be able to use the object in your Sophie book, it won’t be imported into 
your Sophie book. You might use this option if you have an enormous movie on your 
computer that you want to use in several Sophie books. 

File > Export Resources will ask you for a location; all the resources in your Sophie 
book will be exported to a new folder in that location. Use this to get media out of a 
Sophie book.

2.4.2. EDIT
The Edit menu generally contains things having to do with manipulating objects on a 
Sophie page. 

Edit > Undo undoes the last thing you did in Sophie. You can also do this by pressing 
command/control-Z. 

Edit > Redo redoes the last thing you undid in Sophie. Use this if you undid some-
thing by mistake. You can also do this by pressing command/control-Y. 

Edit > Cut removes the selected text, frame, or timeline event and copies it to the 
clipboard for later pasting. You can also do this by pressing command/control-X. 

Edit > Copy copies the selected text, frame, or timeline event to the clipboard for later 
pasting. You can also do this with command/control-C. 

Edit > Paste will paste whatever you have on the pasteboard at the current insertion 
point. The current insertion point for text is where the cursor is. Frames will be 
pasted at the same location on the current page. Timeline events will be pasted start-
ing at the current playhead position. You can also do this by pressing command/
control-V. 
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Edit > Test Mode will switch Sophie into Test mode (if in Author mode), or into 
Author mode (if in Test mode). You can do the same thing by checking the Reader 
Mode box in the status bar of any Sophie book or by pressing command/control-T. 

Edit > Spell Check will look for the next misspelled word from the current cursor 
insertion point in text. 

Edit > Copy Location of Selection will copy a reference to text that is currently se-
lected in Sophie book to the clipboard. This is only partially implemented in RC7 and 
shouldn’t be used. 

Edit > Show/Hide Flow Connections will make flow connections visible or invisible. 
Different flows are given different colors; you can drag the connections between the 
different flows on a page back and forth. 

Edit > Show/Hide Rulers will make the Sophie rulers visible on the current book. 

2.5. Keyboard shortcuts 
Here is a list of keyboard shortcuts you can use in Sophie. Command/control means 
that you should press the command key on a Mac or the control key on a PC. 

command/control-A. If text is selected, this selects all text in the current flow. If no 
text is selected, this selects all objects on a page. 

command/control-C. If text is selected, this copies the text to the clipboard. If no text 
is selected, this copies any objects that are selected to the clipboards 

command/control-D. If an object or event on a timeline is selected, the object or event 
is duplicated. 

command/control-F brings up the find dialogue. 

command/control-G. If more than one frame is selected, the frames are grouped. 

command-H. On a Mac, this hides the Sophie application. 

command/control-N creates a new book. 

command/control-O opens a book. 

command/control-P prints the currently selected book to PDF.. 
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command/control-Q quits Sophie. If books are open, you’ll be asked whether to save 
them. 

command/control-S saves the current Sophie book. 

command/control-shift-S saves the current Sophie book, prompting for a filename. 

command/control-T toggles test mode. 

command/control-U. If grouped frames are selected, they are ungrouped.

command/control-V. If there is an insertion point in text, this pastes whatever is on 
the clipboard at that point. If there is no insertion point in text, whatever is on the 
clipboard is pasted onto the current page. 

On the Mac, if you copy something on the Mac desktop – an image, audio, video, 
or supported text file – and then paste it into Sophie, the object will be imported into 
the current Sophie book. 

command/control-W closes the currently selected Sophie book. 

command/control-shift-W closes the currently selected window of a Sophie book. 

command/control-X. If text is selected, this cuts the text (copying it to the clipboard & 
deleting it). If no text is selected, any selected objects are cut. 

command/control-Y redoes the last undone operation. 

command/control-Z undoes the last operation. This only works with text. 

command/control-RETURN. If the cursor is inserted into a flow frame and this is 
pressed, a page break is inserted. 

DELETE/BACKSPACE. If a frame or a timeline event is selected, the frame or timeline 
event is deleted. These can also be used in most palettes that contain lists. 

arrow keys. If a frame is selected, the frame is moved one point in the direction 
pressed. In text, the cursor is moved. If nothing is selected, the left and right arrows 
will go forwards or backwards in pages. 

shift-arrow keys. If a frame is selected, the frame is moved 10 points in the direction. 

PageUp/PageDown go forward or backwards a page. 

command-shift-; (Mac) / F7 (Windows/Linux) finds the next spelling mistake.
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2.6. Special keyboard interactions 
There are a few cases in Sophie where keys can be pressed to change interactions. 
These include: 

• Holding down option (on a Mac) or alt (on a PC) when dropping a flow frame. 
This will cause the dropped frame to start a new flow. 

• Holding down control when dropping a book inside another book. If this is done, 
the dropped book is embedded in the book it is dropped on, rather than linked. 

• Selecting a movie on a timeline and pressing control will toggle whether the movie  
is visible on the page when the movie is not playing. 

• In general, when selecting, pressing command (on a Mac) or control (on a PC) will 
extend the section. This can be used with frames on the page, resources listed in a 
palette, and events on a timeline. 

• If you select one resource in a palette, then hold down shift and select another one, 
all the resources between them will also be selected. 

• Selecting one page, then holding down shift and selecting another page will select 
all the range of pages. 

• Holding down shift while dragging the corner of a frame will resize the frame 
proportionately. 

• When typing, command-click (on a Mac) or control-click (on a PC) will select the 
frame of the text and bring up the frame halos.

2.7. Book windows 
Sophie books appear inside the Sophie workspace. Each book has its own window. A 
book window has a few main parts.

2.7.1. The title bar
At the top of the book window is the title bar. This contains the book’s name. After 
the book’s name will appear the words “(author mode)” or “(test mode),” indicating 
which mode Sophie is in.

If you double-click the title bar, the book will be minimized so that just the title bar 
is visible. Double-clicking it again will return the book to its normal window.
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At the right side of the title bar is a little square, which will maximize the book size 
in the workspace, and an X icon. Clicking the X icon will close the book.

2.7.2. The visible page
Below the title bar is the book proper, where the page of the book appears. 

At the bottom right of the page is a drag handle, which can be used to resize the 
book’s page size. (Currently all pages of a Sophie book are the same size.) If you drag 
this you’ll see the current width and height of the book above your cursor. Stop drag-
ging to leave the book that size. Note that changing the page size is different from 
changing the size of the book’s window.

If a book’s page size is bigger than the book’s window, the page will grow scroll 
bars inside the book window. You can use these scroll bars to move to areas of the 
page that aren’t visible; you may want to adjust the book window size.

2.7.3. The status bar
At the bottom of the book window is the status bar, which has controls for specifying 
what you see in the book window. 

At the left is the book zoom percentage. By default, this is set to 100%. You can 
choose another percentage from the drop-down menu of zoom settings. Zooming 
will change the book window size as much as possible; if the page size is larger than 
can fit in the window, the book will grow scroll bars.

Next to the zoom control is the status bar search. If you enter text in this field and 
press RETURN or the up and down buttons next to the text field, the currently visible 
page will be searched for that text; if it is found, it will be selected. If there are more 
than one results on the page, you can use the up and down buttons to move between 
them. 

To the right of the search field are the left and right page buttons and the current 
page number. The page number is displayed in the form “1/4”: this means that 
you’re currently looking at page 1 and there are a total of 4 pages. You can press the 
left arrow and right arrow to go back and forward a page. 

To the right of the page controls is the frames toggle. If this is turned on, the 
frames around objects on the page will be shown, as will the lighter gray frames that 
indicate margins and padding. You can turn this off to get a better feel for how your 
finished book will look. When you switch into test mode, frames are turned off; when 
you switch out of test mode, frames are turned on.

At the right of the status bar is the test mode toggle. If this is turned on, Sophie 
will go into test mode. Test mode applies to all open books, not just the book from 
whose window you toggle test mode. Test mode can also be toggled by choosing Edit 
> Test Mode from the menu bars, or pressing command/control-T.
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2.7.4. The edges and corners of the book window
If you move your mouse over the edges or corners of a Sophie book window, you’ll 
see the cursor change. Dragging the edges or corners of a Sophie book window will 
change the window size. Any edge or corner will work this way.

2.7.5. Embedded book windows
Clicking a link in a Sophie book in test mode may open an embedded book in its own 
window. Embedded books opened in this way have a different window than regular 
Sophie books. 

Embedded book windows cannot be resized. Double-clicking on the title bar will 
minimize the book to just the title bar; clicking the X at the right of the title bar will 
close the window.

2.7. Test mode 
Sophie can operate in either Author mode or Test mode. By default, Sophie opens in 
Author mode. In Author mode, you can create an edit books. In Author mode, links 
that you’ve created are disabled – otherwise they might cause trouble and get in your 
way. If you want to see how your book will appear to a reader, switch into Test mode. 
In Test mode, all links are functional and your book will appear just as it will in So-
phie Reader. 

The title bar of every open book window in Sophie indicates which mode Sophie is 
in: after the name of the book, the text “(author mode)” or “(test mode)” appears.

You can switch back and forth from Author mode to Test mode by pressing 
command/control-T, by checking the Test mode check box in the status bar of every 
book window, or by selecting Edit > Test Mode from the menu bars.

In Test mode, the right flap disappears entirely. You can’t edit your book in test 
mode; you can only interact with it. You can still use the pages tab on the left to 
change pages; you can add stickies or highlight text as well. If your book has com-
ment frames, you’ll be able to add comments to your book.
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3. Working with books 

3.1. Making a new book 
There are several ways to make a new Sophie book. You can go to the File menu and 
choose New Book, or you can press command/control-N. Both of these options will 
present you with a dialogue box asking for the size of the book you want. At the top of 
this window is a drop-down menu with some predefined sizes; if you don’t like any of 
those sizes, you can enter any width and height you like in the fields below.

Sophie books can be as big as you like; however, if the book is larger than the So-
phie window, it will have scroll bars and you won’t be able to see all of it at once. 

Another way to create a new Sophie book is to drag a frame or a resource to the 
workspace. A new book will be created containing just that frame or resource. You 
can drag resources either from the resource palettes of an existing book or from your 
computer directly into Sophie.

3.2. Using book templates  
You can also create a new Sophie book by dragging a book template to the workspace. 
Book templates are found in the book templates palette in the components tab; some 
book templates come with Sophie, and some are found in your local book templates 
directory. Book templates contain frames and backgrounds; it’s easier to start with a 
book template than it is to start from scratch. 

If you drag a book template onto a page of another Sophie book, a new book will 
be created that is inside of the existing book. This is called an embedded book. 

3.3. Making book templates 
To make a book template, go to the File menu and choose Save Book Template. By 
default you’ll be taken to the default book template directory; book templates that are 
saved in this directory appear in the book templates palette. When a book is saved as 
a book template, most content is deleted; essentially a book template is a collection of 
empty pages and frames ready for text insertion. Book templates can’t contain links 
or timelines in Sophie 1.0; if you try to save a book as a book template that contains 
links or timelines, a warning will appear and you will not be permitted to save the 
book template.
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On the Mac, the default book template directory is /Users/username/Library/
Application Support/Sophie/library/book-templates, where username is the username of 
the account you’re logged in under. On Windows, the default book template directory 
is C:\Documents and Settings\username\Application Data\Sophie\library\book-templates, 
where username is the username of the account you’re logged in under. On Linux, 
the default book template directory is TK.

You don’t have to save book templates from inside Sophie to make the templates 
appear in this directory. If you manually move book templates into the default book 
template directory, they will appear in the book templates palette the next time you 
restart Sophie.

You can’t delete book templates from inside Sophie; if you want to get rid of your 
book templates, you need to go to the default book template and delete the books 
from there. Some of the templates that appear in the book templates palette can’t be 
deleted because they come with Sophie.
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4. Working with frames 

“Frame” can mean both objects on a Sophie page – like images and movies – and the 
kind of frame that you drag out and fill with text. Both types of frame have common 
properties: when you click on the outside of the frame, the same halos pop up. All 
frames have a frame appearance halo (a little square), a frame properties halo (a little 
house), a link halo (a little chain), and an anchor halo (a little anchor). In addition, all 
frames have a clock halo which can be dragged to a timeline to put the frame on a 
timeline. In the upper right corner of every selected frame, there’s a green square 
which can be dragged to rotate the frame, the rotate handle, and in the center of a 
frame there’s a plus sign in a circle, the drag handle, which can be used to drag the 
frame elsewhere on the page. 

If your cursor is in text in a frame, you won’t see the frame halos, you’ll see the text 
halos. You can select the frame and get to the frame halos quickly by holding down 
the command key (on a Mac) or the control key (on a PC) and clicking anywhere in 
the frame. Or you can just click the outside edge of the frame.

4.1. Changing the size and position of a frame 
The orange edges of a selected frame can be dragged back and forth to change the 
width and height of a frame; dragging a corner will change both width and height at 
the same time. (Hold down the shift key while you drag to keep width and height 
proportional). 

Frames can be moved on the page by selecting them and using the arrow keys; 
each time you press an arrow key, the frame will move by 1 point. If you hold down 
shift and an arrow key at the same time, the frame will move by 10 points. You can 
usually move a frame by clicking inside it and dragging with the mouse; if the con-
tent of the frame is text, drag the frame by the little + sign to avoid inserting your 
cursor in text. 

You can also change the size and position of a frame by using the frame properties 
halo. The top section of the frame properties halo contains the frame’s current posi-
tion on the page, width, and height. There’s a little grid of dots; one of them is lit up. 
The lit-up dot is the frame’s control point: if that dot is in the center, the x and y val-
ues for the frame are of the center of the frame. If the control point is the upper left, 
the x and y values are for the upper left corner of the frame. The control point also 
controls how the frame is resized: if you make a frame twice as wide and your control 
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point is the center, the frame will stay centered in the same place on the page and get 
wider. If your control point is on the left and you do the same thing, the frame’s left 
side will stay in the same place; the right side will jump to the right, becoming wider. 

By default, the width and the height of a frame change proportionately. That is, if 
your frame is 100 points wide and 50 points hight and you double the width to 200 
points, the height will double as well to 100 points. To the right of the width and 
height is a little chain; if you click this, the chain will break, meaning that width and 
height are no longer proportional. When the chain is broken if you change your 100 × 
50 point frame to 200 points wide, the height will stay at 50 points. Click the chain 
again to change it back to proportional settings. 

4.1.1. CHANGING WRAPPING PROPERTIES 
If you have a frame full of text and you drop an image over it, you’ll see that the text 
will reflow itself to wrap around the image. While this is the default setting, you can 
change this setting for every frame on a Sophie page: it’s possible that you want your 
image to obscure your text. There are three buttons that control wrapping; they’re 
below the x- and y-coordinates and the width and height in the frame properties halo. 
By default, the one in the middle is selected. This means that text will flow around the 
frame you have selected. If you select the icon on the right, text won’t flow around the 
frame you’ve selected. If you select the icon on the left, text will flow around the 
frame you’ve selected and not appear to the left or right of the frame. 

If you’ve rotated a frame and selected the second option for wrapping, Sophie will 
wrap text around the rotated edges of the frame.

4.1.2.MULTIPLE SELECTION, GROUPING, AND ALIGNING FRAMES 
You can select more than one frame at a time by selecting one frame than holding 
down command (on a Mac) or control (on a PC) and clicking another frame. You can 
repeat this to select multiple frames. Multiply-selected frames can be dragged about; 
you can change their size, though this may have strange effects. If you want certain 
frames to always move together, you can press command/control-G to group them. 
Whenever you select one of a grouped frame, other frames grouped with it will also 
be selected; when you move one of the frames, you’ll move all of them. The same 
happens if you rotate them or resize them. Frames can be ungrouped by selecting the 
group and pressing command/control-U. 

When multiple frames are selected, the align halo appears. If you click the align 
halo, the align HUD will appear. The align HUD contains six different buttons, 
which will align frames on different axes. The top left button, for example, will make 
the top edges of all frames start at the same place: the top edge of the first-selected 
frame, which is given a red outline. 
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4.2. Setting borders and fills 
To set borders and fills, open the frame appearance halo, the leftmost of the halos. 
You are presented with options for filling, borders, and drop shadows for your frame. 
Not all of these work all the time: for example, if you have a movie, you can put a drop 
shadow and a border on it, but not a fill. It already has a fill: the movie itself. If you’re 
using an image and it’s has transparency, however, you can change the fill on the im-
age: the fill you choose will appear behind the transparent parts of the image. 

There are five fill styles, which can be chosen from the drop-down menu: none, 
solid, radialGradient, linearGradient, and pattern. None means the frame has a 
transparent background. Solid means the frame has a solid-colored background. Click 
the square next to the drop-down menu to choose the color; the default is white. Ra-
dial and linear gradients are mixes of color; you can click the square next to the fill 
style to set up how the gradient will work. Pattern means that an image will be used 
as the background for the frame. Drag an image from the resources into the white 
box next to the drop-down menu; you can click on the box to set up how the back-
ground pattern is displayed. 

Beneath fill styles are border controls: you can choose a width and color for your 
frame’s border. By default, frames have no border, so the default width is 0 pts; the 
default color is black. Enter a value (in points) for the width of the border you want 
and click the black square to change the color of the border. 

At the bottom of the frame appearance HUD are the drop shadow controls. By de-
fault, frames have no drop shadow, but you can add one by changing the drop shadow 
offsets. There are two values: the horizontal offset and the vertical offset. If either of 
these is not zero, a drop shadow will appear. (These values can be negative if you 
want to have a drop shadow that is to the left or above your frame.) Beneath the offset 
values is a slider that controls the hardness of the drop shadow: if you slide it all the 
way to the left, the drop shadow will be hard and square, if you slide it to the right it 
will become fuzzy. The square to the right of the slider sets the color of the drop 
shadow; by default it’s black and slightly transparent. 

4.3. Making links with the link halo 
Frames can be links just like text. To make a frame a link, select the frame and click 
the link halo to open the link HUD. The link halo is described here. 

Once you’ve made a frame a link, the link color halo appears to the right of the link 
halo. If you open this, you’ll see something that looks very much like the frame ap-
pearance HUD. At the top of the HUD is a drop-down menu that lets you choose 
normal, over, and pressed. Normal is selected by default: the part that looks like the 
frame appearance HUD shows what the frame and border settings for the frame are 
normally. If you choose over, you can change how the frame, border, and drop 
shadow look when the reader moves their mouse over the frame. If you choose 
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pressed, you can change the settings for how the frame looks once the link has been 
triggered. 

There are also four boxes at the bottom of this HUD: one for normal, one for over 
(what the reader sees when their mouse is over the link) one for pressed (what the 
reader sees when the link is being triggered) and one for visited (what the reader sees 
after the link was triggered). You can drag images into these boxes; they will be used 
as the background for the frame when the visitor moves the mouse over the frame, 
activates the link, or has triggered the link. Effectively, this lets you make buttons. 
This does exactly the same thing as using an image for a pattern in the different 
states of the link; if you’d like to make buttons that way, you can do that. These drop 
boxes can only be used for frames; you can’t make buttons out of images or movies.
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5. Working with text 

5.1. Using the character halo 
The character halo appears when your cursor is in text; it’s the left-most halo. Click-
ing it opens the character HUD. The most prominent setting is the font you’re cur-
rently using, which is in a drop-down menu. You can choose another font from this 
list. In the character HUD are also your font’s size; you can pick a size from the drop-
down menu, or you can type in your own size. If the font you’ve chosen has a bold or 
an italic face, you can press the “B” or “I” button to choose a bold or italic version of 
the font. The box next to the font name is the color of the type, black by default; if you 
click on this, you can choose another color for the font. 

If you open up the halo move by clicking the down arrow at the bottom of the 
HUD, you’ll see more options. The checkered box on the right selects the background 
color of the text. By default this is transparent; if you choose a more opaque setting, 
your text will appear highlighted. 

The A\V checkbox turns kerning on or off; kerning is on by default. And the AV 
with a percentage field next to it controls the tracking for the selected text. By default 
this is 0%; if you enter a number that’s greater than 0, more space will be added be-
tween the characters. If you enter a number that’s less that 0, space between charac-
ters will be taken away.

The “Reset Style” button removes any character setting that is different from the 
paragraph’s character setting. 

If you have text selected, the changes you make in the character HUD will only 
affect that selection. If you don’t have text selected, changes made in the character 
HUD will affect anything you write immediately after making changes in the HUD. 
If you want to change the layout of an entire paragraph, you should use the paragraph 
HUD. 

5.2. Using the paragraph halo
Clicking the paragraph halo opens the paragraph HUD. The paragraph HUD con-
trols text settings for entire paragraphs: any changes that you make in the paragraph 
HUD will be made not just to what you have selected but to the entire paragraph that 
the selection is in. You don’t need to have any text selected to use the paragraph HUD 
– it’s enough that your cursor just be inserted into text. If you have text selected 
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across paragraphs, all changes made in the paragraph HUD will be applied to all 
paragraphs even partially selected. 

At the top of the paragraph HUD is the paragraph style name, which is by default 
“default.” Paragraph styles contain all the formatting information for a paragraph; 
they can be saved so that you can reuse them. If you want all your headers to be cen-
tered and in bold type, and all your body text to be left-aligned and in regular type, 
you could use saved paragraph styles to make sure they’re alike. You don’t have to use 
saved paragraph styles if you don’t want to; but if you don’t, you’ll have to reformat 
paragraphs by hand. To use a paragraph style that’s already been saved, pull down the 
drop-down menu and select the style in the list. To save your current paragraph for-
mat as a saved paragraph style, click the little disc to the right of the drop-down 
menu. You’ll be prompted for a name; if you choose a name that’s already taken, 
you’ll be replacing that style. 

Beneath the style-saving drop-down box, there are the linespacing controls. Line- 
spacing is how much space there is between the lines in a paragraph. (This isn’t the 
same thing as adding space above or below a paragraph: there’s a separate control for 
this.) You can control linespace in different ways: you can use a multiple of lines (sin-
gle or double-spacing); single spacing is the default. Or you can choose a unit of 
space (in points, picas, or millimeters) if you want a fixed amount of linespacing. 
First choose your unit (or keep it the default “line”); then change the multiple (for 
line spacing) or the height (for fixed spacing). 

Below the linespacing controls on the left is the first-line indent, which controls 
whether your paragraph is indented. This is measured in points. This value can also 
be negative if you want to have your paragraph outdented (as in a bulleted list, for 
example). If you want to do this, you should have a positive value in your left indent 
(see below). 

To the right of the first-line indent are the paragraph alignment controls. There are 
four buttons: for left-aligned, center-aligned, right-aligned, and fully justified. The 
default is left-aligned. 

If you open up the paragraph style palette by clicking the down arrow at the bot-
tom of the paragraph, more controls become visible. From the top and left to right the 
first four are left indent, right indent, space above paragraph and space below para-
graph. 

Below those the next style setting. The next style setting specifies which style will 
be used when you press RETURN at the end of the paragraph and a new paragraph is 
created. By default, the next style will be the style of your current paragraph. 

If you open up the paragraph style HUD even further, you’ll see character settings 
that look just like the character HUD. Changes made to this section are applied to the 
entire paragraph, not just the selected text. This is the best way to apply different 
fonts and sizes.
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5.3. Using paragraph styles 
At the top of the paragraph HUD is the paragraph style name, which is by default 
“default.” Paragraph styles contain all the formatting information for a paragraph; 
they can be saved so that you can reuse them. If you want all your headers to be cen-
tered and in bold type, and all your body text to be left-aligned and in regular type, 
you could use saved paragraph styles to make sure they’re alike. You don’t have to use 
saved paragraph styles if you don’t want to; but if you don’t, you’ll have to reformat 
paragraphs by hand. To use a paragraph style that’s already been saved, pull down the 
drop-down menu and select the style in the list. To save your current paragraph for- 
mat as a saved paragraph style, click the little disc to the right of the drop-down 
menu. You’ll be prompted for a name; if you choose a name that’s already taken, 
you’ll be replacing that style. 

Saved paragraph styles can also be used in the next style setting of the paragraph 
HUD. By default, the next style is the paragraph itself. In some cases, however, you 
might want the next style to be something else: if you have a header paragraph style, 
you might want the next paragraph that appears when you hit RETURN to be a body 
text style. To make this happen automatically, open the paragraph HUD for the 
header paragraph and choose the body text’s style as the next style.

In the current version of Sophie, paragraph styles can’t be deleted. Two paragraph 
styles exist by default in Sophie: “default,” which is the default style for text in non-
flow and flow frames, and “comment,” which is the default style for text in comments 
in comment frames. Both of these styles can be redefined.

5.4. Using the link halo 
To make a link out of text, you need to select text. When this is done, the link halo 
appears to the right of the paragraph halo. Click it brings up the link HUD. The link 
HUD includes three windows that are used to represent these three parts of the link. 
The top drop-down menu lists possible triggers. The middle drop-down menu lists 
possible actions to take. And the third drop-down menu changes depending on what 
kind of link is selected. If the action is to open a URL, you can type in the URL in the 
third box. If the action is to open a timeline, you can drag the timeline from the time- 
line palette to the third box. If the action is to show or hide a frame, drag the little 
anchor near the box to the frame you want to show or hide. 

The + and – at the bottom of the link HUD allow you to make more complex inks: 
the same frame or text can be part of several different links. 

5.5. Searching text 
There are three different ways to search text in Sophie. There is the status bar search 
window, the searching palette, and the search & replace palette. 
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The status bar page search is the simplest way to search text in Sophie. Enter text 
in the field and press the down button (to search forward from where you currently 
are in text) or the up button (to search backwards from where you currently are in 
text). This type of search will only return results on the page that you’re on. 

If the text you’re searching for appears in your book, you’ll be taken to the page on 
which it appears and the text will be highlighted. You can press the buttons again to 
find another occurrence.

The Searching palette, in the tools tab, gives you a list of results with some context. 
Type in the text you’re looking for in the field at the top of the palette and hit RE-
TURN. A list of all occurrences in text will be provided in the palette; to go to one of 
them, click it in the list. You’ll be taken to that page and the text will be selected.  

The search & replace palette is used to replace text. If you enter text in the search 
field then click the Previous or Next button, the previous or next occurrence of the 
text will be highlighted. If you enter something in the replace field, you can use the 
Replace button to replace the first found instance; pressing the All button will replace 
all instances of that text. You can press command/control-F to get to this palette 
quickly. You don’t need to replace to use this palette; you can use this palette just to 
find things in your text.

5.6. Using the spellchecker 
Pressing command-shift-; (on a Mac), F7 (on Windows or Linux) or going to Edit > 
Spellchecker will look for the next misspelled word from the current cursor insertion 
point in text; if found, the misspelling will be selected. More advanced spellchecking 
can be done with the spellchecker palette, in the tools palette. The palette will be 
opened automatically when the spellchecker is invoked.

5.7. Using multiple flows 
By default, every flow frame that you drag to a page uses the same flow. So if you drag 
out a flow frame, put a lot of text in it, and put another flow frame on the same page, 
the text will flow from one frame to the next, because it’s assumed that they are con-
nected. 

This isn’t always what you want to do. Imagine that you have a five-page story in 
English; you want to put it in a book where it will appear side by side with the same 
story in Spanish. For this situation, you want to use two different flows. The English 
story might go through a frame on the left on page 1 to page 5; the Spanish story 
might go through a frame on the right on page 1 to page 5. The English story uses 
one flow while the Spanish story uses another. 

To create a flow frame that uses another flow, hold down the option key (on a Mac) 
or the alt key (on a PC) when you drop the frame on the page. (Note that this is not 
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the same as dragging the frame out while holding down option or alt; you need to 
hold down option or alt just before you drop the frame on the page.) A new flow will 
be created. If you don’t hold down the option or alt key, the flow frame that is created 
will use the existing flow. While it won’t be immediately apparent that this is a new 
flow, it should have a cursor blinking in it. You can tell which flow is which by going 
to Edit > Show/Hide Flow Connections, which will give every flow frame a colored 
border around it. Different flows will have different colors. 

When you’re in this mode, you can also use frame halos to change the connections 
or the flows of frames. If you have two frames on the page that use the same flow, an 
arrow will be shown connecting the two frames in the direction of the flow. The ar-
rows come from a little box at the lower right of every frame; you can drag from this 
box to another frame to connect the frames. If the frames have different flows when 
you do this, the second one will be changed to the first flow. 

If you click the little arrow at the top left corner of a flow frame in this mode, you’ll 
get a drop-down list of all the different flows in the document. The flow the frame is 
currently using will be checked. You can select a different flow for the frame by 
choosing a different flow. Be careful, though – this is a very easy way to mess up a 
complicated book if you’re not sure what you’re doing.
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6. Working with media 

6.1. Adding resources to Sophie 
To add resources to a Sophie book, drag them into Sophie’s window. If resources are 
dropped on a page, they will appear on the page and in the book’s resources; if re-
sources are dropped onto the library tab, they’ll be added to the resources but won’t 
immediately appear on the pages of the book. You can also add resources to Sophie 
by using File > Import File, which will prompt you to find resources to add to Sophie. 
(If you use File > Link to File, the resources will appear in the resource palettes, but 
the file won’t actually be imported into your Sophie book. You might use this if you 
have several Sophie books that all use the same enormous movie on your computer if 
you don’t want your books to be equally enormous.) 

Not all resources have to be on your computer: you can use resources that are on 
the Internet if they are the kind of file that can be imported to Sophie (an MP3, for 
example). To do this, you need to know the URL for the file. Go to File > Link to Re-
source from URL and enter the URL. (If you use File > Import Resource from URL, 
the resource will be downloaded and included in your Sophie book.) An icon for the 
resource will be added to the resources tab in the appropriate palette; you can drag it 
from there to the page. A good reason to do this is if your book uses enormous re-
sources but you don’t want your book file to be enormous. You might also do this if 
you are using resources that are being updated outside of Sophie. 

6.2. Using time-based media 
Time-based media (audio and video) work slightly differently from other sorts of me-
dia. When you select one of these on a page, you’ll see a halo to the left of the anchor 
halo, the time-based media halo; clicking it opens the time-based media HUD. This is 
a simple HUD: it includes checkboxes that ask if you want the media to play when 
shown and whether a controller should be shown. If play when shown is checked, the 
media will start playing as soon as the page of the book that it appears on is opened. 
(What this checkbox does, actually, is to create a link: open the link HUD to see what 
it does.) If show controller is checked, play and pause buttons appear below the audio 
or video that the reader can use. 

It’s also worth noting that time-based media by default comes with links built into 
them: they’re set so that if you double-click them they’ll play, and if you single-click 
them they’ll stop. If this isn’t what you want them to do, you can delete these two 
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links. You can also change these links: you could change a movie so that it plays on 
mouse over and stops playing when the reader moves the mouse off of the movie.

Controllers and links on audio and video don’t work in Sophie Author unless 
you’re in Test mode.

6.2.1.Audio annotations
Audio annotations are another form of time-based media. When you’ve recorded 
audio inside of Sophie, it behaves just like audio that’s been added to Sophie in any 
other way.

To add audio annotations to your book, you need to use the audio recording pal-
ette, in the annotations tab. The audio recording palette lets you record audio through 
your computer’s microphone (or line-in) inside of Sophie. To use this, click the red 
Record button; there will be a slight delay (the words “Preparing to record” will ap-
pear to the right of the Play button) and then a clock will start increasing, letting you 
know that Sophie is recording. Click the Stop button when you’re done; click the Play 
button to playback what you’ve just recorded. If you like it and want to keep it, click 
the Save button, which will add the audio in the audio palette of the resources tab. By 
default, recordings are given the time and date they were recorded. If you don’t want 
to keep it, just don’t hit the Save button.
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7. Working with links

7.1. Using the link HUD
The link HUD is used to make links, which make a Sophie book interactive. Links 
can be both text – when the reader clicks on a word or words to do something – or 
frame based – when the reader clicks on a frame or image to do something. There are 
a number of different types of links that can be made in Sophie.

Links in Sophie have three parts: something that triggers the link (the reader click-
ing a frame or text, for example, or the page opening), an action that is performed (a 
timeline is played, a frame is shown, the book jumps to the next page), and finally 
what’s used to perform that action (the timeline to play, the frame to show, the page 
number to jump to). 

The link HUD includes three windows that are used to represent these three parts 
of the link. The top drop-down menu lists possible triggers. The middle drop-down 
menu lists possible actions to take. And the third drop-down menu changes depend-
ing on what kind of link is selected. 

7.2. The different kinds of link triggers
If you pull down the drop-down menu for link triggers, you’ll see the list of link trig-
ger options. By default, this is set to “mouseUp,” but that’s just one of the possible 
settings for this part of the link HUD:

• mouseDown will trigger the link as soon as the reader clicks the mouse button.

• mouseUp will trigger the link when the reader lets go of the mouse button. This is 
the default link; it gives the user a little time to change their mind if they decide 
they didn’t actually want to click the link. 

• mouseDoubleClick will trigger the link when the reader double-clicks on the link: 
that’s two clicks in a row, like you’d use to open an application.

• mouseEnter will set the link off when the reader moves the mouse above the link. 

• mouseLeave will set the link off when the reader moves the mouse – which had 
been above the link – outside of the link.
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• pageShows will set off the link as soon as the reader turns to the page. If the 
reader is on the page of a book with one of these links in author mode and 
switches into test mode, the link might not fire until you go to another page and 
come back to the original page.

• frameShown will set off the link when the frame that the link is set in (or the 
frame that the text is in, if it’s a text link) first becomes visible. This could be the 
same as when the page shows; however, if the frame is hidden by default, it could 
only be when the frame is made visible.

• frameHidden will set off the link when the frame that the link is set in (or the 
frame that the text is in, if it’s a text link) is hidden by the result of a close frame or 
toggle frame action from another link. 

7.1. The different kinds of link actions
There are also a number of different actions that can be chosen. There is no default 
for link actions; you’ll need to choose one. Different actions require different things 
in the third field of the link HUD. Here are the options:

• Open URL will open a URL, probably in a web browser. Type (or paste) a URL into 
the third field of the link HUD to complete the link. 

• Go to Page will go to a specific page in your book. Type the page number into the 
third field. If that page number exists, triggering the link will go to that page; if it 
doesn’t exist, nothing will happen. 

• Go to Selection will go to a specific text selection in the current Sophie book or 
another Sophie book on your computer. To use this, go to the location you’d like to 
link to, select the text, and choose Edit > Copy Location of Selection. Then make a 
Go to Selection link; put your cursor in the third field and choose Edit > Paste or 
press command/control-V. Some XML will be pasted in the field; when the link is 
triggered, Sophie should go to the selected text, opening up the book if it has to.

• Show Frame will show a frame that’s currently hidden. To use this action (or Hide 
Frame or Toggle Frame), drag the flag to another frame (images, video, and audio 
also work) on the page and drop it. The frame’s name should appear in the third 
field of the link HUD. Show Frame is really only useful if there’s also a Hide 
Frame or Toggle Frame link somewhere else on the page. When Show Frame is 
chosen, the frame that is its target will automatically be hidden; you can undo this 
by changing the frame’s visibility in the page structure palette. 
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• Hide Frame will hide a frame on the page. Drag the flag to another frame on the 
page; that frame will instantly disappear until another link shows the frame. 

• Toggle Frame will toggle the visibility of a frame on the page. If the frame is cur-
rently shown, Toggle Frame will hide it; if it’s hidden, Toggle Frame will show it. 
Making a frame the subject of a Toggle Frame action will hide it. When Toggle 
Frame is chosen, the frame that is its target will automatically be hidden; you can 
undo this by changing the frame’s visibility in the page structure palette.

• Open Book in New Window will open an embedded or linked book in its own 
window. To make this kind of link, drag the name of another book from the books 
palette or the embedded books palette to the third field. (Dragging the flag to the 
name should work as well.) If you use a book in the books palette, the book will be 
linked; after you do this, the name of the book linked will appear in the embedded 
books palette, but that doesn’t necessarily mean the book is embedded. 

• Play from Beginning will play a timeline from the beginning. To make this (and 
the other timeline actions) work, drag a timeline from the timelines window into 
the third field of the link HUD.

• Play will play a timeline. If the timeline hasn’t been played in the book, or has been 
played all the way to the end, Play will play the timeline from the beginning. If the 
timeline has been paused, Play will resume from where the timeline stopped playing.

• Pause will pause a currently playing timeline. If the timeline is not playing, noth-
ing will happen. If a Play link is triggered after a Pause, the timeline will start from 
where it left off. 

• Rewind will move the playhead of a timeline specified in the third field back to its 
start. Rewind followed by Play does the same thing as choosing Play from Beginning.

• Previous Page will go to the previous page of the book, if there is one. If there’s not, 
it won’t do anything. This link action doesn’t require anything in the third field.

• Next Page will go to the next page of the book, if there is one. If there’s not, it 
won’t do anything. This link action doesn’t require anything in the third field.

• Beep will make a horrible clanking noise when the link is triggered. It doesn’t require 
anything in the third field. This is useful for testing links, but not for much else.

• Show in Front does the same thing as Show Frame, except that it will move the 
shown frame in front of everything else on the page when it is shown. 

37

Link action options in the drop-down menu



• Toggle in Front does the same thing as Toggle Frame, except that it will move the 
shown frame in front of everything else on the page when it is shown. 

7.1. The third field of the link HUD
What goes in the third field of the link HUD depends on what’s chosen as the link 
action; you need to choose a link action before you can put something in that box. For 
some of these commands, you drag the flag next to the third field to something else 
in Sophie. Here are the link actions and what they take in the third field:

• Open URL: a URL.

• Go to Page: a page number.

• Go to Selection: XML from an Edit > Copy Location of Selection command. 

• Show Frame, Hide Frame, Toggle Frame, Show in Front, Toggle in Front: the 
name of a frame on the same page as the link. While you could conceivably type in 
the name of a frame in the third field, it’s easiest to drag the flag to the frame.

• Open Book in New Window: the name of a currently open book or embedded 
book. While you can type in the name of a book, it’s easiest to drag the book’s 
name from the books palette or the embedded books palette to the third field of 
the link HUD. You can also drag the flag from the link HUD to the book’s name in 
either of those palettes. 

• Play from Beginning, Play, Pause, Rewind: the name of a timeline. You can type in 
a name of a timeline, or you can drag the flag to a timeline in the timelines palette. 
You can also drag the timeline to the third field of the link HUD.

• Previous Page, Next Page, Beep: these actions require nothing in the third field.

7.1. Making more complicated links
Clicking the + and – at the bottom of the link HUD allow you to make more complex 
links: the same frame or text can be part of several different links. You can make sev-
eral different actions that are triggered the same way (clicking a frame could start 
three different timelines, for example) of you can have different actions with different 
triggers (mousing over a word does one thing, while clicking on the word does an-
other). Clicking + will add a new link segment; clicking – will take away a link seg-
ment. You can have as many link segments as will fit in the Sophie window.
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2. Working with pages 

2.1. Using page templates 
A page template is a collection of frames that you want to appear on more than one 
page. The page template also contains the page background. Page templates are used 
to save time. If you want a header graphic at the top of every page and a footer 
graphic at the bottom of every page, you could manually place the graphics on every 
page in your book. But it’s much faster just to apply a page template which automati-
cally places those graphics. Frames that are on a page can be moved to the page tem-
plate; frames that are on the page template can be removed from the page template. 
In Sophie, you can edit frames that are on page templates just as you can edit frames 
that are not on page templates, though there may be ramifications: if you’re editing 
text in a frame that appears on pages 1–5 on page 1, you may be changing pages 1–5 
just as you’re changing page 1.

Every page in Sophie uses a page template, though a page template may not have 
any frames on it. You can see which page templates are in your book by looking in the 
page template palette in the components tab: all the page templates used by your 
book are listed in that palette, with orange dots next to the ones that are in use.

You can see which page template your page is using by going to the page structure 
palette, in the pages tab. If your page uses frames that are part of the page template, 
they’ll be listed under the page template. 

If a Sophie book is built from a book template, the book template may come with a 
number of page templates. A Sophie book that’s built entirely from scratch comes 
with two page templates: “default page template,” which is the page template used by 
the first page in the book by default, and “blank page template,” a blank page. 

2.1.1. Applying page templates 
To apply a page template to a page, drag the page template you want to use to the 
page in the page view palette to which you want to apply the page template. The page 
thumbnail will turn red when the dragged page template is over it; drop it and the 
page template is applied to the page. 

If you want to apply the same page template to multiple pages, click the first page 
in the page template, shift-select all additional pages you want to change, then drag 
the page template you want to use to the page palette. The pages will light up red. 
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2.1.2. Adding pages 
Pages are added to a Sophie book in exactly the same way that page templates are 
applied to pages. Select the page template of the page you want to add (or “blank page 
template” if you want to add a blank page) and drag it to the list of pages. Instead of 
dropping it on a page, drop it before or after a page: a red line will appear showing 
the place in the book where the new page will be added. 

You can also add pages by selecting a page in the page palette and control-dragging 
above it or below it in the page palette until you see a horizontal line between pages. 
The new page will be inserted between those pages; it will use the page template from 
the dragged page. If you drop it on an existing page, the new page will be added after 
that page.

(Pages can also be added by a flow frame that’s full. When a page is created this 
way, the new page will have the page template of the page that created it.) 

2.1.3. Making & modifying page templates
To make a new page template, or to change an existing page template, use the page 
structure palette. See the next section for more information on how this works.

2.1.4. Deleting page templates
If you have page templates in your book that are not in use, you can delete them by 
selecting them in the page template palette and pressing DELETE. 

2.2. Using the page structure palette 
The page structure is used for more advanced control of frames on pages; if you want 
to create or modify page templates, you’ll need to use it. The page structure palette is 
minimized by default; it appears underneath the pages palette in the page tab. 
Double-click the title bar to open it.

The page structure palette lists four different things: 

• The page entry. This is at the top of the list; everything else appears below the 
page in the entry. This also displays the page number. If the page has been 
changed via the page halo and the page template has not been saved since, there’s 
an asterisk next to the page number. Selecting the page in the page structure pal-
ette makes the page halo appear on the page. 

• Frames that are on the page. Audio, movies, and images are identified by their 
filenames; text frames are identified by a snippet of the text in the frame. Frames 
on the page are also distinguished by number (starting from 1 and incrementing); 
text frames are split into “flow” and “nonflow”. Frames are listed in the z-order in 
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which they appear; the top frame in the list appears above frames lower in the list. 
If you select a frame from the page structure palette, it will be selected on the page 
and vice versa. 

• An entry for the page template being used. This is in the form “default page 
template (layout 1)” where “default page template” is the page template currently 
being used. If the frames on the template on this page are different from the 
frames on the saved page template (if there are more or less frames, or if the 
frames have been moved), there is an asterisk next to the entry. (In future versions 
of Sophie you may be able to use more than one page template on a page; for now, 
you’re limited to a single one.)

• Frames on the template. If frames are listed below the template entry, the frames 
are on the template. These frames are listed in z-order. If a frame has been modi-
fied from its definition on the template, or if a frame on the template doesn’t exist 
on the saved template, there’s an asterisk next to it. If you select one of these 
frames in the page structure palette, it will be selected on the page and vice versa.

Depending on what (if anything) is selected in the page structure palette, buttons 
appear at the bottom of the palette with possible actions. These buttons are: 

• Nothing selected in palette. “Save page as template” button. 

• Page selected. “Save page as template” button. 

• Frame not on template selected. “Move to template” button and “Save page as 
template” button. 

• Layout selected. “Save changes to template” button, “Reset to template defaults” 
button, “Save as template” button. 

• Frame on template selected. Nothing unless you’ve just moved the frame to the 
template, in which case there are “Move from template” button, “Save page as 
template” button. 

So we have in total six buttons: 

• Save page as template. The user is prompted for a name for the page template. 
This button moves all frames on the page to the template. If the user has chosen 
the name of an existing page template, that page template is replaced. (Save as 
template does the same thing.) 
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• Move to template. This button moves a frame that is not on a template onto the 
current template in use on the page. The page template is not saved; if you want to 
do that, choose the “Save changes to template” button. 

• Move from template. This button is only useful if a frame has been moved to the 
template with the “Move to template” button and you decide that you don’t want 
the frame on the template before you save the changes to the template. If you 
press this button, the frame will be moved off the template. 

• Save changes to template. If objects on the template have been modified (or de-
leted), this button saves the changes to the currently used template. If changes have 
not been made to the template on the page, pressing this button won’t do anything. 

• Reset to template defaults. This button undoes all changes done to frames on the 
template (or frames added to the template before saving changes) and returns to 
the defined template. Be careful; you may lose changes by pressing this button.

The two kinds of non-flow frames behave differently when they are on a template. 
When a non-flow frame is on a template, the frame and its content appear on every 
page that uses that template; however, the frame can have different content on every 
page. If a non-flow (template content) frame is on a template, every page that uses 
that template will have exactly the same frame. Editing the content on any page that 
uses that frame will change the content on every page that uses that template. (Com-
ment frames work the same way: comment (template content) frames have exactly 
the same content on every page in which the template that holds them is applied.)

 If you’ve moved a frame to a template and you want to get the frame off the tem-
plate, the best way to do this is to select the frame, cut it, and then immediately paste 
it. Cutting the frame will remove it from the page (and the template); pasting it will 
restore it to the same place on the page but not on the template. After you’ve done 
this, you’ll probably want to resave your page template.

1. Using the page structure palette to change frame visibility
Next to each frame’s entry in the page structure palette is a checkbox for frame visibil-
ity. By default, every frame in Sophie is shown. However, you can uncheck a frame if 
you want to hide it. Note that the next time you come to the page or open the book, 
the frame will be hidden. It can be useful to temporarily hide frames; be sure to make 
them visible again when you’re done.

Link actions that show or toggle a frame automatically hide the frames that they 
show or toggle. These frames can be made visible again by checking their check-
boxes. When frames are on a timeline, they’re shown by default; if you want them 
hidden until the timeline plays, uncheck their checkboxes.
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3. Working with embedded books 

3.1. Creating embedded books 
Embedded books can be embedded in two different ways. A fully embedded book 
lives entirely inside the parent book: when you send the parent book to someone, the 
embedded book goes with it, like a media resource that’s in the book. A linked em-
bedded book doesn’t live inside the parent book: while it displays in the same way as 
a fully embedded book, it lives somewhere else. If you send someone a parent book 
without the linked embedded book, the linked embedded book won’t show up. The 
reader will be prompted for the location of the embedded book.

Embedded books in Sophie can appear both on the page of the container book – 
like a frame – or in their own window, opened from a link in Sophie. These books can 
be either fully embedded or linked embedded.

3.1.1. Creating fully embedded books 
A book can be fully embedded in another book if it is made from a book template. To 
make a book template, create a book and save it as a book template in the default 
book template directory. The book template that you’ve created will appear in the 
book template palette. From there, it can be dragged to the page of the book you want 
to embed it in. Text or media that’s inserted into an embedded book created in this 
way will be saved inside of the container book. 

Another, less useful way to create a fully embedded book is to drag an open book 
from the books palette to the page of the book you want to embed it in while holding 
down the control key. When the book is dropped, Sophie will attempt to turn the book 
you want to embed into a book template so that it can be fully embedded. If you don’t 
want to turn the book you want to embed into a book template, this isn’t useful.

(A book that is embedded in either of these two ways will appear on the page 
where you dragged the book template or book to. If you don’t want the embedded 
book to appear on that page (or if you don’t want it to appear on a page at all), select 
the book on the page and press DELETE. The book will be deleted from the page but 
will still exist in the embedded books palette.

An alternate way of fully embedding books is to open the Sophie book file of the 
book you want to contain the embedded book and to drop the book you want to em-
bed into the Contents folder. The next time you open the container book in Sophie, the 
book you dropped into the Contents folder will appear in the embedded books palette.

43

The embedded books palette 
for a book with many 

embedded books



3.1.2. Creating linked embedded books
To create a linked embedded book, open both the book you want to embed and the 
book that will be the container book. Drag the icon for the book you want to embed 
from the books palette to the page of the container book on which you want the em-
bedded book to appear. Both books are still independent: if you make a change in the 
embedded book when the container book is closed, the changes will be visible the 
next time you open the embedded book from the container book. If you want to give 
the container book to someone on a different computer, if they are going to use the 
embedded book, you’ll need to send it along too. 

If you hold down the control key when you drag a book from the book palette to 
the page of the book, Sophie will attempt to convert the book into a template so that 
the book can be fully embedded. This process will strip out all content of the embed-
ded book. This may not work; if it doesn’t, an error message will appear. 

3.1.3. Renaming embedded books
You can rename an embedded book by double-clicking its name in the embedded 
books palette. This doesn’t change the embedded book’s filename; however, it will 
change the title displayed in the embedded book’s title bar if the embedded book is 
displayed in its own window.

3.1.4. Deleting embedded books
If you decide that you want to delete an embedded book from your book, you can se-
lect it in the embedded books palette and press DELETE or BACKSPACE. 

3.2. Displaying embedded books 
Embedded books can be displayed two ways: on the page, like an image or a movie, or 
in their own window. The same book can be embedded in multiple places in the 
same parent book. 

If you’ve created an embedded book by dragging a book or book template to the 
page of another book, it will display on that page by default. This doesn’t need to be 
the case: you can select the embedded book on the page (by clicking its frame) and 
press DELETE or BACKSPACE to remove it from the page. The embedded book will 
still be in the embedded books list; you can drag it from there to the same page or 
another page in the book. 

A book that’s embedded on a page of a parent book can be moved around the page 
like any other object. To turn the pages of such a book, the reader needs to click in the 
book to move focus to that book, then use the arrow keys to turn the pages. When 
focus is in the embedded book, the page palette will show thumbnails for the pages 
in the embedded book, not the pages in the parent book.
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An embedded book can also be opened in a separate window. To do this, make a 
link; for the link action, choose Open Book in New Window. Then drag the embed-
ded book from the embedded book palette to the third field in the link HUD. When 
the link is triggered, the embedded book will be opened in its own window. (An em-
bedded book displayed in this kind of window can be either fully embedded or linked 
embedded.)

Embedded books appear in a window that’s unlike other Sophie book windows; 
most notably, it doesn’t include a status bar or scroll bars . If you want to present in-
formation in an embedded book that appears in its own window, it’s a good idea to 
include navigational buttons if there’s more than one page.
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4. Working with timelines 

4.1. The timeline interface 
There are two major parts of the timeline interface in Sophie: the timelines palette (in 
the timelines tab, in the left flap) and the timeline window, which appears when a 
timeline is opened. There’s also the clock halo on objects on the page, which allows 
objects to be attached to a timeline. And finally, the link HUD contains commands 
related to starting and stopping timelines. 

The timeline palette lists all timelines in the book. Double-clicking an entry in this 
list will open the timeline window for that timeline; pressing DELETE or BACKSPACE 
while you have a timeline selected will remove the timeline from the book. 

At the bottom of the timeline palette are two buttons, which let you add new single 
page or multiple page timelines. 

4.2. Kinds of timelines 
There are two different kinds of timelines. A single-page timeline contains only ac-
tions which are used on that page. A multiple-page timeline turns certain pages at 
certain points in time. Use a multiple-page timeline when you’re constructing a slide-
show where pages turn to audio or video accompaniment; use a single-page timeline 
for most other uses. 

4.3. Using single-page timelines 
Single-page timelines are the simplest kind of timelines. When you create a new one, 
the timeline window will open at the bottom of the screen. The timeline window is a 
special kind of palette in a flap; it can be made shorter or taller and can even be 
pulled out to appear on its own window if you want. At the top of the timeline win-
dow are controls; at the bottom are channels where media or events can be found. 
The controls for the timeline are fairly basic. On the left is the timeline’s name; this 
can be edited to rename the timeline. To the right of the name are rewind and play/
pause button. Clicking these buttons rewinds the timeline or plays it; clicking the 
play/pause button when the timeline is playing will pause the timeline. Next to the 
play/pause button is the current position in time of the playhead. There are also 
boxes for the start, end, and duration of the selected clip. Finally, there’s a loop check-
box: if this is checked, the timeline will loop and keep playing.
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Above the channels is a playhead, which can be dragged back and forth; if there 
are different events visible at different points in the timeline, what’s visible on the 
page will change as the playhead is moved. As the playhead is moved, the current 
time position in the controls above will also change. 

Above the playhead is the slider, which can be used to change the zoom and area of 
the timeline being viewed. By default, the slider is as wide as the timeline window, 
which means that all of the timeline is visible. The more you narrow the slider, the 
more the timeline is zoomed in. You can then move the slider left and right to see 
earlier or later positions in the timeline. 

Media and events appear in the channels on the timeline. To add media on the 
current page to your timeline, select the object on the page, and drag its clock halo to 
the position on the timeline where you want it to appear. You can also add media to 
timelines by dragging directly from the resource palettes to the timeline; when you do 
this, the object is immediately added to a page (except for audio, which is added only 
to the timeline). 

If an image or a frame is added to a timeline, it will be visible for the duration that 
its event on the timeline appears. That is, if you have a picture that’s on a timeline 
from 1:00 to 2:00, when the timeline plays the picture will not be visible for the first 
minute. It will be visible as the timeline plays from 1:00 to 2:00; if the timeline goes 
past 2:00, it will be invisible again. If audio or video appears on a timeline, when the 
timeline is played the audio or video will be played. By default, the video’s frame on 
the page will be shown when the video is not playing; usually it will appear as a black 
frame.  (If you control-click on a video’s event on a timeline, you can toggle whether 
or not it is visible when the event is not being played.) You can get a good feel for this 
by putting some objects on a timeline and dragging the playhead back and forth: 
when the playhead is over the events on the timeline they become visible. When it’s 
not over them, they’re invisible. 

If you want a frame on the timeline not to be visible at all until the timeline is 
played and the playhead moves over it, you should be sure to uncheck its visibility 
checkbox in the page structure palette. If you don’t do this, the object will appear on 
the page when the reader turns to the page if the timeline isn’t playing.

If you drop a piece of media over an existing channel on the timeline, it will be in 
that channel; if you drop it below an existing channel, a new channel will be created 
to hold that event. Once an event is in a channel, you can move it to another channel 
by dragging it from one channel to another (or to the bottom of the timeline window 
to create a new channel). It doesn’t matter which channel events are in; you can have 
everything in a timeline in just one channel if you want. Channels exist solely so that 
you can organize the events on your timeline if you want to. 

Once a piece of media is on a timeline, you can adjust where it appears on a time- 
line by dragging it back and forth. You can also use the arrow keys: the left and right 
arrow keys move the event backward and forward in time by 1 second, holding down 
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shift plus an arrow key will move the event by 10 seconds. You can also select and 
move multiple events on a timeline: click one event to select it, then hold down shift 
and click other events on the timeline to select them as well. Then use the arrow keys 
or drag any of the events to drag them all. 

You’ll notice when you move an event on a timeline that the event’s Start and End 
positions in the controls at the top of the timeline window change. If you want your 
event to start or end at a precise moment in time, you can enter values in these boxes. 
Note that changing the end position changes the length of the event. You can also 
change the length of an event by changing the value in the Duration box, or by drag-
ging the left or right edge of an event. For audio and video, changing the length of an 
event changes the end point of a clip: if you change the length of an audio clip from 
0:30 to 0:15, the first 15 seconds of the clip will play regardless of whether you 
dragged the left or right edge of the clip to play it. The maximum length of an audio 
or video event is the length of the audio or video itself: you won’t be able to make the 
duration longer than that. 

4.4. Using multiple-page timelines 
The timeline window for a multiple-page timeline is just like the single-page timeline 
window, with the exception that there’s a special channel for pages above the other 
channels in the lower section of the timeline window. Pages can be dragged from the 
pages palette to this channel, where they will appear as events that can be dragged 
back and forth; their duration can be changed. 

If a multiple-page timeline is playing, when the playhead reaches the start of a 
page event on the timeline, the book will turn to that page. In addition, when the 
reader manually turns to a page that appears on a multiple-page timeline, the play- 
head of the timeline will be moved to the point in time at which that page starts, al-
though the timeline will not play automatically. 

There can be no empty space between pages on a page-turning timeline: if you 
have page 1 on a timeline and drag page 2 to the timeline, page 2 will automatically 
start where page 1 ends. If you extend the length of page 1, the start of page 2 will be 
pushed back, and if you make page 1 shorter, page 2’s start time will move forward. 

Pages that appear in the page channel on a multiple-page timeline do not need to 
appear in their natural sequence: while you could have a timeline that showed pages 
1, 2, 3, 4, and 5 at 0:00, 0:10, 0:20, 0:30, and 0:40, you could also show the pages in 
the order 2, 1, 4, 3, 5. You can even put the same page on the same timeline multiple 
pages (the sequence 1, 2, 3, 2,, 4, 2, for example); when you turn to a page that ap-
pears in the timeline more than once, the timeline will move to the first page event 
that appears on the timeline. 
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The other channels in a multiple-page timeline work like the channels on a single- 
page timeline. Keep in mind that if an event is scheduled to happen when its page is 
not visible, it won’t be seen. 

If an object on a multiple-page timeline is on a template that’s used by more than 
one page on the timeline, that object can potentially appear across those pages. For 
example, you could put a movie on the page template used by pages 1 through 5; you 
could then put pages 1 through 5 on a timeline and add the movie to the timeline. As 
the movie plays, the pages will turn.

4.5. Controlling timelines 
To use timelines in a Sophie book, you need to make a link that starts them. There 
are a number of ways to trigger this kind of link: you could start a timeline when a 
page is opened, or when the reader interacts with the book in some way. 

There are four actions in the drop-down menu of link actions that can be used on a 
timeline: 

• Play. This action starts a timeline playing from whatever point the playhead is cur-
rently at. If the timeline has not been played before, it starts from the beginning. 

• Play from beginning. This action starts playing a timeline from the beginning. 

• Rewind. This action moves the playhead of a timeline back to the beginning. It 
doesn’t play the timeline. 

• Pause. This action pauses the timeline: it stops it playing, but doesn’t move the 
playhead. 

Some of these obviously need to be used in conjunction with other links: choosing 
Rewind or Pause won’t actually do anything unless you have a play command some-
where. 

When you’ve chosen one of these actions, you need to drag a timeline from the 
timeline palette to the box below the action. When you’ve successfully dragged a time-
line to the box, the timeline’s name will appear in the box. You can also type in the 
name of the timeline in the box. 
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5. Working with the network 

5.1. Using remote objects 
One of the most basic ways that the network can be used in Sophie is through remote 
objects. Remote objects are objects that live on the network (like a web server) rather 
than on your computer. Remote objects aren’t saved inside of the Sophie book when 
you save it on your computer; they stay on their web server. Using remote objects is a 
good idea if you’re using an enormous movie in your Sophie book, but you want it to 
be small enough so that you can email it to people. 

Any sort of media that can be used in Sophie can be used remotely. To use a re- 
mote object in your Sophie book, you need to know its URL. Then go to File > Import 
Resource from URL. Enter the URL and then click Okay. The remote object’s icon will 
appear in the media palette that it belongs to. You can use the remote object just like 
any other piece of media in Sophie: just drag it to the page. 

When the reader opens a book that includes a remote object, the object will be 
downloaded when the reader gets to the page that the object appears on. If the reader 
doesn’t have a working Internet connection, they won’t see what you intended. If you 
know this is going to be the case, don’t use remote objects in your book. 

5.2. Comment frames 
Comment frames are another way to use Sophie and the network. Comment frames 
require a Sophie Server to function; however, a Sophie book that uses comment 
frames doesn’t need to be on a Sophie Server to function. When a book has comment 
frames, readers can make comments on a book; these comments are uploaded to the 
Sophie Server and are soon made visible to everyone reading a copy of the book. 

To add a comment frame to a book, drag the comment frame out of the compo-
nents palette to a page in your book. A comment frame will appear; in its upper right 
corner there will be a link that says “Add Comment”. Comment frames have frame 
appearance and frame properties HUDs just like regular frames: you can set the 
background color, size, margins, and padding of comment frames just like an ordi-
nary frame. Comment frames don’t have link halos or anchor halos, but they can be 
resized and rotated just like any other frame. 

When a reader clicks the “Add Comment” link, a window will open which asks for 
an “Author” – a name – and a comment. (Comment can be added to a comment 
frame in Test mode or in Sophie Reader, but not in Author mode) After these have 
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been entered, the reader can click buttons marked Commit or Cancel. Commit enters 
the comment; it’s uploaded to Sophie Server. Cancel erases what was just entered and 
closes the window. 

Once a comment has been added, a “Reply” link appears below it. If a reader clicks 
this link, a reply to the comment will be added. Replies are indented; if there’s a reply 
to a reply, it will be indented further. If there are enough comments to fill the com-
ment frame, the comment frame will grow scroll bars.

Comments can be added to any copy of a book that’s open. You need to save a book 
before entering comments in it; after you save a book, any copy of the book that you 
make using File > Save As will share the original book’s comments.

The text of comments in comment frames are in the paragraph style “comment”; if 
you redefine this paragraph style, you can change how your comments appear. 
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6. Working with reader annotations 

6.1. Using stickies 
Stickies are little collapsable windows that a reader or author can add to a book. To 
made a new sticky, go to the annotations tab; in the stickies palette, click the New 
Sticky button. A new sticky will appear on the current page of the current book. You 
can type as much text as you’d like in a sticky; if there’s more text in the sticky than 
will fit, you might need to press the down arrow key to view it. 

You can resize the sticky by dragging its lower right corner; you can move it 
around on the page by dragging the title bar. You can delete the sticky by clicking the 
little X in the upper right corner. You can change the color of the sticky by clicking the 
little color box in the title bar; a color picker will appear, allowing you to pick any color 
you like. 

You can add as many stickies as you want to a book; they can be added by the 
reader or the author. If there are a lot of stickies in the book, it may be useful to hide 
them sometimes. To do this, uncheck the box marked “Show Stickies”. You can ex-
port stickies from a book by clicking the Export Stickies. You’ll be prompted for a 
name to save the stickies as. Once you’ve done this, you can import the stickies file, 
by clicking the Import Stickies button.

6.2. Using the highlighter 
The highlighter works just like a yellow marker. If you select text, you can press the 
Add Highlight button in the highlights palette. It will be given a yellow background.

Highlighted text is listed in the highlights palette in the order in which the text 
appears in the book. If you click on an entry in this palette, you’ll be taken to the page 
on which it appears. 

You can export highlighted text from a book by clicking the Export Highlights but-
ton in the highlights palette. You’ll be prompted for a name to save the highlighted 
text as. Once you’ve done this, you can import the highlighted text file, using the Im-
port Highlights button.
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7. Publishing & Sophie Reader

7.1. Publishing 
Sophie saves books with the extension .spbf. These books can be opened and edited by 
anyone. You may want to publish your book. A published book cannot be edited by 
the reader. Sophie books don’t need to be published to be read in Sophie Reader, but 
publishing can make sense when the book is finished being edited. 

A published book has the extension .sophie. When a published book is opened in 
Sophie Author, it behaves as if it is always in Test mode: links are always active, and 
text cannot be edited. 

To publish a book in Sophie, go to File > Publish Book. You can only publish a 
book when you’re not in Test mode; be sure to turn that off before attempting to pub-
lish your book. A dialogue box will appear asking if you want to include fonts in your 
published book. If you don’t include fonts and readers of your book don’t have the 
fonts in your book installed on their computer, what they see may not be exactly what 
you see: text might reflow. Including fonts will increase the published book size.

The publishing process strips out unused resources from your book. If your book 
includes embedded books, they will be embedded at the moment of publishing.

When a book is published using File > Publish Book, the book is first saved, then 
closed. Then a .sophie book is generated and opened.  

7.2. Sophie Reader
Sophie Reader is used to read books that have been published in Sophie. Sophie 
Reader is a separate application from Sophie; you can’t author books in Sophie 
Reader. Sophie Reader can open both unpublished (.spbf) and published (.sophie) 
books. You can open multiple books at once; they appear in tabs across the top of the 
Sophie Reader window. You can switch books by clicking on a different book’s title.

Sophie Reader doesn’t do anything unless you have a book open. You can open a 
book in Sophie Reader by dragging it from your computer’s desktop to the Sophie 
Reader window, by going to File > Open Book, or by pressing command/control-O to 
open a book.
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7.2.1. The status bar
The status bar appears at the bottom of the Sophie Reader window. It’s much like the 
Sophie status bar, though it’s missing a few of the Sophie controls. 

On the left, there’s the book zoom percentage, by default set to 100%; a different 
zoom percentage can be chosen. If the book is zoomed so that it’s larger than the So-
phie Reader window, the book will grow scroll bars.

To the right of the zoom percentage, there’s the search on page field. This works 
exactly like in Sophie; if you type in text and press the up or down button, Sophie will 
search for the text on the page and highlight it if it finds it. Pressing the up and down 
buttons will find other occurrences of the text on the page if there are any.

And finally on the right there are page-turning buttons and the page number field 
showing the page number. You can enter a page number in this field and Sophie will 
go to that page.

7.2.2. The menu bars
Sophie Reader has a reduced set of menu bars. Here’s what you can find in them:

File > Open Book. This will bring up the open file dialogue box. You can do the same 
thing by pressing command/control-O or by dragging a Sophie book into the Sophier 
Reader window.

File > Open Recent Books. This will bring up a list of books that you’ve opened re-
cently in Sophie Reader. 

File > Close Book. This will close the currently open Sophie book. You can do the 
same thing by pressing command/control-W. 

File > Print to PDF. will generate a PDF of your book, which you could use for print-
ing. If you’re on a Mac, Preview (or the application you’ve set to handle PDFs) will be 
opened with the resulting PDF. If you’re on a Windows PC with Adobe Acrobat or 
Reader, Acrobat or Reader will be opened with the PDF. If you don’t have an applica-
tion associated with PDFs in Windows or on a Linux PC, a message will tell you 
where the PDF has been saved. You can also do this by pressing command/control-P.

Edit > Undo. This will undo the last action that you did in Sophie Reader. You can do 
the same thing by pressing command/control-Z.

Edit > Redo. This will redo the last action you undid in Sophie Reader. You can also 
do this by pressing command/control-Y. 

54

The File menu in Sophie Reader 
on a Mac.

The Edit menu in Sophie Reader 
on a Mac.

(Left) The Annotations tab in 
Sophie Reader



Edit > Cut removes the selected text and copies it to the clipboard for later pasting. If 
you’ve selected text on the page of an open Sophie book, it won’t be removed but it 
will be copied. You can also do this by pressing command/control-X. 

Edit > Copy copies the selected text to the clipboard for later pasting. You can also do 
this with command/control-C. 

Edit > Paste will paste whatever you have on the pasteboard at the current insertion 
point, which in Sophie Reader can be in annotations. You can also do this by pressing 
command/control-V. 

7.2.3. The tabs
There’s only one tab in Sophie Reader: the annotations tab. The annotations tab in 
Sophie Reader contains palettes for highlights and stickies. They function just as they 
do in Sophie.

The highlights palette lists all highlights in the current Sophie book. You can de-
lete a highlight by selecting its entry in this list and pressing DELETE. Clicking on an 
entry will take you to the page on which the highlight appears. Clicking the Add 
Highlight button will highlight the text you currently have selected. Import Highlights 
will prompt you for the location of a file of previously saved highlights. Save High-
lights As will prompt you for a location where a file of the highlights of your current 
book can be stored.

The stickies palette allows you to make new stickies on a Sophie book. Pressing 
the New Sticky button will make a new sticky on the current page. The Enable Stick-
ies checkbox toggles sticky visibility in the book; if this isn’t checked, stickies won’t be 
visible. Import Stickies will prompt you for the location of a file of previously saved 
stickies. Save Stickies As will prompt you for a location where a file of the highlights 
of your current book can be stored.

7.2.4. Full screen mode
Sophie Reader can display Sophie books in full screen mode; in this mode, books are 
zoomed until they appear as large as they can, and no other applications are visible. 
To switch to full screen mode, press F5 or command-option-P (on a Mac) or control-
alt-P (on a PC). In full screen, the tabs to switch between books and the flap on the 
left is not visible; the status bar does appear at the bottom of the page to allow you to 
navigate the book. To get out of full screen mode, press F5/command-option-P/
control-alt-P again.

Movies that are blown up to large sizes in full screen mode may not play as well as 
they might when Sophie Reader is not in full screen mode.
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